Duplicate Jobs Received by ERIS

Incident Report for ETHERFAX

Resolved

Engineers have continued monitoring this and have put additional alerting in place to guard against this on the API side. Additionally, developers are continuing to work on a fix for this issue inside of ERIS.
Posted Jun 09, 2026 - 16:40 EDT

Monitoring

Engineers have continuned to monitor those customer's accounts who are utilizing the ERIS product and are affected by this. This issue is being addressed from two different angles, one on the ETHERFAX API side to understand a condition that causes ERIS to make multiple attempts to retrieve a job and second, from the ERIS side to help guard against this condition should it be encountered.
Posted May 27, 2026 - 17:51 EDT

Identified

Engineers are addressing these issues on the affected customer accounts to prevent the duplicates.
Posted May 27, 2026 - 11:44 EDT

Investigating

Engineers are currently reviewing reports of some ERIS instances pulling inbound faxes multiple times. This incident at this time appears isolated to installs of ERIS.
Posted May 27, 2026 - 10:41 EDT
This incident affected: U.S. API Services (U.S. REST Services) and Canada API Services (Canada REST Services).